Linux版比特币勒索病毒来了:可影响7年前版本

日前肆虐于Windows设备中的“永恒之蓝”蠕虫勒索病毒让全世界不少的电脑用户吃尽了苦头,而由于当时遭遇该病毒攻击的清一色的都是Windows设备,所以当时就有人宣称Linux操作系统和iOS系统不会中毒的理论!

此前,就有安全专家对Mac是否会遭遇病毒攻击进行了论证,根据新华社报道,如今一个被称作是Linux版本的“永恒之蓝”勒索病毒也出现了,此次漏洞最早能够影响到7年前的版本。

Linux版的比特币勒索病毒来了:可影响7年前的版本

据了解,该漏洞来源于一款能够在Linux和Unix操作系统上实现SMB协议的软件――Samba,目前,该软件仍旧被广泛的应用于基于Linux的服务器、NAS网络存储产品和路由器等各种loT智能硬件上!

分析认为,Samba漏洞能够对各种常用的智能硬件造成严重威胁,比如说在智能电视、路由器等设备中,samba文件共享是很常用的服务之一。此前流行于全球的路由器开源固件OpenWrt就受到了这一漏洞的影响,可能导致路由器被黑客控制,劫持或监听网络流量,甚至是给用户的网络设备中植入木马,对于普通用户来说这何尝不是一个恐怖的概念!

Linux版的比特币勒索病毒来了:可影响7年前的版本

而和Windows版本的“永恒之蓝”勒索病毒相比,Samba漏洞相对来说比较简单,更容易被攻击,但其威力和Windows版可以说是棋力相当,而且可以远程执行任意代码,甚至可以根据服务器的情况,攻击者可能以root的身份执行。

目前,还漏漏洞的攻击方式已在网络公开,随时都有可能被不法分子恶意利用!

Linux版的比特币勒索病毒来了:可影响7年前的版本

根据Phobus安全公司创始人DanTler称,目前有约477,000台安装了Samba的计算机暴露了445端口,虽然其中能够被攻击的Samba版本无法进行精确统计,但也有安全研究人员检测到了目前有110,000台计算机运行着官方已不再继续提供技术支持的SAMBA版本,所以,还漏洞能够对多少用户造成影响自然也就不言而喻了!

不过,值得庆幸的是,和Windows有所不同,Samba的SMB功能默认是不打开的,必须通过用户手动开启!

Linux版的比特币勒索病毒来了:可影响7年前的版本

目前,对于该漏洞,360网络安全响应中心和360信息安全部已发出预警信息,并针对会受此影响的用户发布了解决办法,有需要的用户可以自行检索解决。

到这里,笔者不禁考虑,Windows版本的“永恒之蓝”勒索病毒在全球肆虐之时,微软方面对早已停止支持的Windows XP和Windows 2003发布了特别补丁,那么Samba方面是否也会为早已停止服务支持的版本增发漏洞补丁呢?

Linux版的比特币勒索病毒来了:可影响7年前的版本

当然,在这里笔者也建议,请务必根据360等服务提供商提供的漏洞解决办法对自己的固件设备进行漏洞处理,并能够即使的关闭路由器、智能电视等设备上的Samba文件共享服务,防止有不法分子利用漏洞进行攻击。

本文最后更新于2017-05-26 23:10,如存在内容或图片失效,请留言反馈,我们会及时处理,谢谢!
文章来源:栋科技
版权链接:Linux版比特币勒索病毒来了:可影响7年前版本
正文到此结束
EMLOG

热门推荐

喜欢就评论一下吧!

发表评论

    avatar
    • 嘻嘻 大笑 可怜 吃惊 抛媚眼 调皮 鄙视 示爱 哭 开心 偷笑 嘘 奸笑 委屈 抱抱 怒 思考 流汗
    0
    努力提交中...